Re:Linked
Re:Linked
ionicons-v5-j
ionicons-v5-q

Ubuntu 18.04 安装

Created: 1362 char, ~6 min to read

This post is published over 180 days ago since the last update. Therefore, information in this post might be outdated.


于是今天咱把 Ubuntu 18.04 装上了。

硬盘引导

主要的过程是装 EasyBCD (个人用户免费)、装载 neogrub、写 boot.cfg。尝试 Arch Linux 和 Manjaro 没成功(所以装的 Ubuntu)。

EFI 用户注意一下,有些地方不太一样。

参考文章: 1, 2

输入法

本地自带 iBus。根据传统换到 fcitx + 搜狗拼音(中川韵输入法请随意)。上搜狗 Linux 输入法官网下载包安装就行。我是用软件中心装的,dpkg -i似乎不能处理依赖问题。

(实际上,iBus 挺不错的,但是 fcitx + 搜狗输入法个人用得更舒服一些。)

WPS Office

下载安装即可。比 LibreOffice 还是好用很多的。和 WPS Windows 的界面差不多。

zsh

信仰!信仰!Oh My Zsh! 不解释啦。

shadowsocks

这里稍微费了点劲。Ubuntu 源里的 shadowsocks 包是不支持 chacha20(-ietf)-poly1305 的。比较不错的方法是装 pip 后直接从源上 clone(参考README)。可执行文件会在 ~/.local/bin 里(这个目录是在 $PATH 中的)。

网易云

本来想用ieaseMusic,不过装不上,后来还是用了官方版。不料官方版在第二次起不来了…提示无法启动canberra-gtk-module、安装libcanberra-gtk-module后未果,遂卸载。

不过实际上网易云的网页版是很好用的!不装客户端啦 :)

Telegram

PPA ppa:atareao/telegramtelegram 包。

OBS Studio

PPA ppa:obsproject/obs-studioobs-studio 包。

Visual Studio Code

6月23日修改:建议直接使用 VSCode 官网的 deb 包安装。 umake 安装的 code 在 GNOME 还能用,切到 KDE 下就用不了了。

先装 ppa:ubuntu-desktop/ubuntu-makeubuntu-make 包,然后:

1
umake ide visual-studio-code

之后会让你同意微软的协议。

很多网上的内容说是umake web visual-studio-code,那个可能是原来的分类。